Содержание

Требования к монтажу

Инструкции по монтажу кабеля:

  • Инструкция по монтажу оптического кабеля типа ТПОд2, ОМП, ОВП производства завода «Инкаб»
  • Инструкция по монтажу и эксплуатации кабеля марки ДПТ
  • Инструкция по монтажу ДПОм, ДПОд, ТПОм, ТПОд
  • Инструкция по монтажу, вводу в эксплуатацию и эксплуатации ОКГТ с приложениями
  • Инструкция по прокладке в кабельную канализацию
  • Инструкция по прокладке в грунт
  • Инструкция по прокладке в ЗПТ
  • Инструкция по монтажу и вводу в эксплуатацию ГТК

 

Требования к монтажу:

  • Кабели предназначены для прокладки ручным и механизированным способом.
  • Разделка кабеля и монтаж должны производиться способами и инструментами, исключающими его повреждение.
  • Монтаж кабелей должен производиться с применением муфт, зажимов и других аксессуаров, зарегистрированных соответствующим образом в Минкомсвязи России.
  • Технологический запас кабеля должен наматываться на твердую оправку с надлежащим натяжением.

 

Требования при монтаже кабеля марок ТПОм, ТПОд:

  • Создавать перед муфтой технологический запас оптического кабеля длиной не менее 8 метров в виде бухты диаметром 0,3 м;
  • Освобождать для разварки в муфте не менее 2 метров волокна;
  • Между подвесом кабеля и последующей сваркой строительных длин соблюдать временной интервал около недели, но не менее одних суток.

 

Невыполнение данных рекомендаций может привести к росту затухания ОВ при отрицательных температурах:

Температура монтажа кабеля не ниже -30°С
Радиус изгиба кабеля при прокладке, монтаже и эксплуатации не менее 15 диаметров кабеля
Длина участка осевого закручивания кабеля на угол ±360 градусов не менее 4 метров
Допустимый статический радиус изгиба для кабелей, прокладываемых в канализации не менее 250 мм
Допустимый статический радиус изгиба оптического модуля не менее 20 диаметров модуля

 

Требования по монтажу


ООО «Альянс ПромЭнерго»

e-mail: [email protected] ru

Общие требования

1. Для уменьшения вероятности повреждения пневматические компоненты целесообразно извлекать из упаковки непосредственно перед началом монтажных работ.

2.Перед началом монтажа продуйте трубопроводы, чтобы удалить скопившиеся в них частицы и капли конденсата


3.При уплотнении резьбы тефлоновой лентой отступите от торца на 1.5-2 витка, чтобы исключить попадание обрезков ленты в пневмосистем


4.При сборке резьбовых соединений не превышайте рекомендуемые моменты затяжки и длины свинчивания.


При монтаже оборудования для подготовки сжатого воздуха

1.Располагайте фильтры, маслораспылители и конденсатоотводчики вертикально и «головой вверх».


2.Следите за тем, чтобы направление потока соответствовало маркировке на корпусе пневмоэлемента.


3. Если конденсатоотводчик снабжается отводной трубкой, ее длина не должна превышать 5м. Не допускается направление трубки вверх и ее пережатие, препятствующее потоку конденсата


4. Устанавливая регулятор давления, обеспечьте свободное пространство в радиусе не менее 60 мм от рукоятки


При использовании по назначению оборудования для подготовки сжатого воздуха

1. Следите за уровнем конденсата, накопившегося в резервуаре фильтра, своевременно сливайте конденсат


2. Для заправки маслораспылителей используйте масла типа ISO VG32 Class 1 (без присадок). Следите за уровнем масла в резервуаре


SHELL Torcula 32 Т30 ГОСТ 32-86

TEBOIL Slide oil 32 и др.

3. При заправке маслораспылителей AL30-AL60 нет необходимости сбрасывать давление в линии. Просто выкрутите пробку из заливочной горловины, залейте масло и вкрутите пробку


При техническом обслуживании оборудования для подготовки сжатого воздуха

1. Заменяйте фильтрующий элемент через 2 года работы или по достижении перепада давлений на фильтре 1 бар – что раньше наступит (некоторые фильтрующие элементы заменяются через 1 год – см.руководство по эксплуатации).


2. Проверяйте состояние поликарбонатных резервуаров фильтров и маслораспылителей. Механические повреждения (трещины, царапины) не допускаются.


3. Для очистки поликарбоната применяйте бытовые нейтральные моющие средства. Синтетические масла, разбавители, трихлор, керосин и др. ароматические углеводороды, например, ацетон, вызывают охрупчивание и растрескивание поликарбоната, поэтому их применение не допускается.


При монтаже пневмораспределителей

1. Располагайте пневмораспределитель так, чтобы его шильдик был хорошо виден.


2. Рекомендуется устанавливать бистабильные пневмораспределители так, чтобы ось золотника располагалась горизонтально, а при наличии вибраций – перпендикулярно их направлению.

Ускорение не должно превышать 5 G.


При использовании по назначению пневмораспределителей

1. Пневмораспределители VP4000 требуют распыления масла в сжатом воздухе


2. Допустимая продолжительность нахождения электромагнита пневмораспределителя в непрерывно включенном состоянии – 30 дней.


3. Для переключения бистабильного пневмораспределителя длительность подачи управляющего сигнала должна быть не менее 0.1 секунды.

Исполнительные механизмы

1. При монтаже уделяйте особое внимание согласованию осей штока и перемещаемой им нагрузки. Рассогласование осей приводит к повышенным боковым нагрузкам на шток.


2. Прежде чем присоединять нагрузку к штоку, переведите его в полностью утопленное положение. При закручивании резьбового соединения удерживайте шток от проворота ключом за имеющиеся лыски.


При использовании по назначению исполнительных механизмов

1. Оберегайте шток пневмоцилиндра от загрязнений и механических повреждений


2. Избегайте приложения вращательного момента к штоку, защищенному от проворота. Для таких нагрузок применяются цилиндры с направляющими.


3. В целях безопасности будьте внимательны при подаче давления в пневмопривод, т.к. шток цилиндра при этом может прийти в движение.


При техническом обслуживании исполнительных механизмов

1. Периодически проверяйте состояние креплений пневмоцилиндра, подтягивайте ослабшие резьбовые соединения.

2. Контролируйте состояние штока пневмоцилиндра. Шток должен быть чистым, гладким и блестящим.


3. Проверяйте герметичность уплотнений, прежде всего – уплотнения штока. При обнаружении признаков износа уплотнений замените их, используя ремкомплект.


При монтаже трубки и фитинги

1. Располагайте точки крепления трубопроводов на расстояниях, соответствующих ГОСТ 18460-91

2. Не опирайте трубопроводы на пневмоэлементы, устанавливайте крепления труб рядом с пневмоэлементом (на случай его демонтажа, чтобы трубы не остались без опоры).


3. Следите за радиусом изгиба пластиковых трубок: он не должен быть меньше минимально допустимого значения. Это особенно актуально для трубок из нейлона и тефлона, т.е. наиболее жестких.


4. Применяйте штатный инструмент для резки трубок. Это позволит избежать косых срезов и смятия концов трубок.


5. Фитинги SMC можно соединять с трубками других производителей, если отклонение их диаметра от трубок SMC не превышает допустимого (см.в каталоге).


Требования к монтажу электропроводки: правила укладки

Если вы планируете выполнить монтаж электропроводки, тогда вам необходимо помнить о том перед монтажом следует изучить все правила. Все требования, которые связанны с электромонтажом в жилых и нежилых зданиях прописывают в ГОСТ, ПУЭ и СНиП.

В этой статье мы рассмотрим современные требования к монтажу электропроводки.

Конечно, в этих документах прописаны не все нормативы и поэтому все факторы необходимо трактовать отдельно. Чтобы вы могли соблюдать пожарную и электрическую безопасность, тогда вам следует изучить наши собственные требования.

Требования к монтажу электропроводки

Теперь требования предъявляются не только к монтажу электропроводки, но и к сечению кабеля и номиналов защитной автоматики. Если вы желаете подробно изучить этот процесс, тогда следует перейти к нашим рекомендациям.

Сначала вам необходимо изучить требования, которые предъявляются к монтажу электрики. Если вы изучите эти пункты, тогда точно сможете выполнить качественный монтаж электропроводки.

  1. Электроснабжение жилого дома следует выполнять от сети в 220 или 380 Вольт. Во время выполнения монтажа также следует сделать систему заземления, которая будет иметь тип TN-C-S.
  2. Монтаж открытой проводки обязательно должен выполняться только в специальных кабель-каналах или электрических плинтусах.
    В сырых помещениях монтаж проводки можно выполнить на изоляторах.
  3. Прокладку скрытой проводки следует выполнять в перекрытиях или специальных нишах, которые для этого предназначены. Если вы выполняете скрытую прокладку, тогда линия должна проходить по поверхностям, которые не подвергаются возгоранию.
  4. Для электромонтажа следует использовать кабель, который имеет медные жилы. Алюминиевые провода можно использовать только для прокладки электричества от столба к дому.
  5. Если кабель будет иметь специальную защитную оболочку, тогда его можно прокладывать через стены без применения металлических трубок.
  6. Незащищенные изолированные провода можно прокладывать через наружные стены в трубах, которые выполнены из полимерных материалов. В сухих помещениях вам необходимо будет установить специальную изолирующую втулку. В сырых помещениях в СНиПе указано использовать воронку.
  7. Согласно ПУЭ незащищенные изолированные провода запрещается проводить открыто по поверхности потолка и стен.
    Также прокладывать свои проводники запрещается в пустотах панелей квартир. Проводить незащищенную изолированную проводку допускается только на изоляторах.
  8. Фазный и нулевой провод запрещается проводить по отдельности.
  9. Прокладывать проводку следует вертикально либо горизонтально. Если вы будете выполнять монтаж электрики по кротчайшему пути, тогда это может нарушить правила безопасности.
  10. Квартирный щиток вам следует устанавливать на высоте 80-170 см от пола. Это предотвратит доступ к электрическому щитку. Если вы желаете изучить другие требования по установке электрического счетчика, тогда следует перейти в соответствующую статью.
  11. Прокладывать проводку нельзя по поверхностям, которые будут подвергаться нагреву.
  12. Выполнять проведение электромонтажных работ необходимо при температуре не ниже -15 градусов.
  13. Номинал розеток должен составлять 16 А.
  14. Во влажных помещениях степень защиты должен быть IP Это требование можно считать актуальным для ванных, кухни или бани.
  15. Минимальная высота установки розетки от пола должна составлять не менее 30 см.
  16. Для каждой комнаты следует выполнить не менее одной точки освещения.
  17. В ванную комнату вам необходимо провести отдельную линию электропроводки. Также линия должна быть оснащена автоматическим выключателем.
  18. Домашняя сеть должна состоять из трех групп.
  19. Если вы выполняете монтаж проводки в полу, тогда по правилам допускается выполнять не более двух поворотов.
  20. Если вы выполняете крепление подрозетника, тогда запрещается использовать монтажную пену.
  21. Нельзя штробить перекрытия и стены с пустотами.
  22. На ванной нельзя выполнять установку бра. Во время испарения влаги светильник может просто лопнуть.
  23. В деревянных домах следует использовать только негорючий кабель.
  24. Во время проведения монтажа электрической проводки запрещается использовать провод ПУНП.

Это все требования по монтажу электропроводки в частном доме или квартире. Как видите с кирпичными домами проблем будет намного меньше чем с деревянными.

Соединение провода и выбор сечения

Во время выбора проводов вы также можете столкнуться с определенными запретами к которым относят:

  1. Место ответвления провода в дальнейшем не должно подвергать механическому воздействию. Изоляция в месте соединения должна быть прочной и соответствовать всем требованиям.
  2. Провода, которые прокладывают внутри стен обязательно должны иметь запас прочности.
  3. Коммутацию жил в трубах выполнять запрещается. Все соединения необходимо выполнять только в распределительных коробках.
  4. Выполнять скрутку провода категорически запрещено. Лучше использовать специальные элементы, которые предназначены для соединения провода.
  5. Выполнять соединение алюминия с медью допускается только в распределительных коробках.

Это были основные требования к соединениям электропроводки в жилых и производственных помещениях. Теперь вы можете ознакомиться с таблицей, в которой указано минимальные сечения жил для электромонтажных работ.

Также вам необходимо постараться выбрать правильное сечение кабеля. Выполнить необходимый расчет вам поможет наш калькулятор по расчету сечения кабеля. Теперь вы можете просмотреть видео, в котором указаны правила пожарной безопасности.

Это все современные требования к электропроводке в частном доме и квартире. Как видите, на данный момент есть огромное количество нюансов, которые следует учесть.

Читайте также: ошибки при монтаже электропроводки.

6.1. Общие требования к монтажу трубопроводов ПОСТАНОВЛЕНИЕ Госгортехнадзора РФ от 10.06.2003 N 80 "ОБ УТВЕРЖДЕНИИ ПРАВИЛ УСТРОЙСТВА И БЕЗОПАСНОЙ ЭКСПЛУАТАЦИИ ТЕХНОЛОГИЧЕСКИХ ТРУБОПРОВОДОВ"

действует Редакция от 10.06.2003 Подробная информация
Наименование документПОСТАНОВЛЕНИЕ Госгортехнадзора РФ от 10.06.2003 N 80 "ОБ УТВЕРЖДЕНИИ ПРАВИЛ УСТРОЙСТВА И БЕЗОПАСНОЙ ЭКСПЛУАТАЦИИ ТЕХНОЛОГИЧЕСКИХ ТРУБОПРОВОДОВ"
Вид документапостановление, правила
Принявший органгосгортехнадзор рф
Номер документа80
Дата принятия01. 01.1970
Дата редакции10.06.2003
Номер регистрации в Минюсте4738
Дата регистрации в Минюсте19.06.2003
Статусдействует
Публикация
  • На момент включения в базу документ опубликован не был
НавигаторПримечания

6.1. Общие требования к монтажу трубопроводов

6.1.1. Монтаж трубопроводов и блоков коммуникаций (далее - трубопроводов) следует производить в соответствии с требованиями настоящих Правил, разработанного плана производства работ (ППР) и проекта.

Монтаж трубопроводов взрывопожароопасных производств с блоками I категории взрывоопасности следует, как правило, осуществлять на основе узлового или монтажно-блочного метода.

6.1.2. Не допускается отступление от проекта и ППР без проведения согласования в установленном порядке.

6.1.3. При монтаже трубопроводов следует осуществлять входной контроль качества материалов, деталей трубопроводов и арматуры на соответствие их сертификатам, стандартам, техническим условиям и другой технической документации, а также операционный контроль качества выполненных работ. Результаты входного контроля оформляются актом с приложением всех документов, подтверждающих качество изделий.

6.1.4. Отклонение линейных размеров сборочных единиц трубопроводов не должно превышать +/- 3 мм на 1 м, но не более +/- 10 мм на всю длину.

6.1.5. Изделия и материалы, на которые истекли расчетные сроки, указанные в документации, могут быть переданы в монтаж только после проведения ревизии, устранения дефектов, испытания и других работ, обеспечивающих их качество и безопасность применения.

6.1.6. Условия хранения изделий и материалов для монтажа трубопроводов должны соответствовать требованиям технической документации.

6.1.7. Если труба в процессе монтажа разрезается на несколько частей, то на все вновь образовавшиеся части наносится клеймение, соответствующее клеймению первоначальной трубы.

Требования к монтажу кабельных лотков

Монтаж несущих кабельных конструкций состоящих из лотков (листовых, проволочных, лестничных), соединительных и поворотных элементов, крепежных приспособлений, лотковых крышек и различных комплектующих, вне зависимости от условий должен производиться в строгом соответствии с ПУЭ.

Требования и рекомендации по монтажу:

  • В металлических кабельных лотках могут размещаться изолированные провода, не имеющие бронирующей оплетки с сечением, жил до 16мм2 и напряжением не выше 1000В.
  • Рекомендуется размещать лотки на высоте не менее в помещениях общедоступного назначения и на любой высоте в технологических помещениях с обученным для работы в данных условиях персоналом.
  • Принцип укладки кабеля в лоток может быть любым, но лучше следовать данным рекомендациям: при размещении проводов в один слой в ряд необходимо оставлять отступ между ними (рекомендовано не менее 5 мм), при укладке пакетов, пучков в один слой отступ необходимо увеличить (рекомендовано не менее 20 мм), для укладки в несколько слоем можно игнорировать отступы.
  • Укладка пучками: диаметр пучка не должен превышать 100мм, количество проводов не более 12, а также не более трех четырёхжильных проводов, рекомендуемый шаг увязки при вертикальной укладке , при горизонтальной не менее 4,5м.
  • Укладка кабеля при отрицательных температурах окружающей среды. Зависит от марки кабеля, но если брать изделия достаточно хорошего качества, то для них актуальны следующие параметры: до -15°C прогрев кабеля не требуется, от -15°C до -40°C необходимо предварительно прогреть кабель что бы не повредить его при монтаже, ниже -40°C монтаж нежелателен или вовсе запрещен, кабель становится хрупким и может не выдержать монтаж даже с прогревом в данных условиях. Точную информацию по условиям монтажа кабеля смотрите в документации от производителя.
  • Если кабельная линия будет пересекаться с трубопроводом, то необходимо в обязательном порядке обойти данный участок на достаточном расстояние.
  • Если лотки планируется использовать в качестве цепи защиты, то необходимо предусмотреть заземление.

Подобрать подходящий лоток можно в онлайн калькуляторе: расчет заполняемости кабельного лотка.

Фото: пример прокладки кабеля в лотках.

Фото: виды укладки кабеля в лоток.


Монтаж кабельных лотков

На этапе расчетов нагрузки техническим специалистом подбирается оптимальное расстояние между опорами для лотков, чем крепче лоток (зависит от толщины стали), тем больше может быть расстояние между опорами, но если брать усредненные цифры, то расстояние должно быть примерно 2м. Также учитывается вид монтажа: настенный, потолочный, напольный. Помимо этого, каждое помещение/объект имеет определенный рельеф и сложные участки с изгибами, подъёмами, спусками, разветвлениями и переходами на другой тип несущей конструкции, в таких местах может потребоваться увеличить число опорных точек.

Закрепление лотков на несущих конструкциях выполняется при помощи болтового соединения.

Опоры фиксируются дюбелями, анкерами, сваркой.

Лоток и опорная конструкция должны быть надежно закреплены.

Монтаж проводки

Проводка должна быть заранее подготовлена к укладке в лоток. При необходимости секции кабеля в лотке могут разделяться перегородкой(ми). Кабель фиксируется стяжками либо хомутами.

Маркировка кабеля

Обозначения или маркировка кабеля необходима и является неотъемлемой частью каждой кабельной сети, проложенной должным образом. Провода маркируются в начале и конце, а также в местах ответвлений и подключений оборудования. Каждая секция проводов маркируется отдельно, обозначения должны быть четкими и долговечными, могут маркироваться группой только отдельные мелкие элементы, относящиеся к одной группе.

Документация по лоткам

Обычно продукция имеет документацию, в которой указаны все характеристики изделий, в частности: материал, из которого изготовлено изделие, антикоррозийные качества, температурный режим, огнестойкость, электропроводность, устойчивость к механическому воздействию (при наличии). Также указываются условия, в которых предусматривается установка и эксплуатация изделий.

Фото: пример монтажа проводки.

Подробную информацию по интересующим вопросам можно получить у наших специалистов:
Телефон: 8 (800) 600-57-36 (звонок по России бесплатный)
E-mail: [email protected]

Требования к монтажу запорной арматуры

Запорная арматура является неотъемлемой частью любого трубопровода вне зависимости от его размещения или предназначение.

Наряду с правильным хранением и соблюдением норм производства, важное значение имеет непосредственный монтаж запорной арматуры в трубопровод.

В данной статье мы остановимся на основных требованиях к монтажу запорной арматуры, без который просто не обойтись:

1. Перед монтажом запорной арматуры в обязательном порядки производится чистка трубопровода, а так же самой арматуры (если она была на хранении). Очистка производится в ручном режиме при помощи щёток и напора воды или пара.

2. При установке запорных задвижек не допускается перемещение за шток, так, как это может привести к поломке.

3. Установка запорной арматуры производится на прямолинейных участках, монтаж арматуры на изгибе трубопровода или на неровных участках запрещён. Соблюдение данного условия вызвано тем, что на данных участках трубопроводов возникают перепады давления, что негативно скажется на работе запорной арматуры, а так же сказывается на герметичности соединения арматуры с трубопроводом.

4. Если монтируемая запорная арматуры имеет большой вес, то необходимо обеспечить опоры, которые будут её поддерживать, в противном случае возникает дополнительная нежелательная нагрузка на трубопровод и места соединения.

5. Если осуществляется монтаж фланцевых приборов, то перед установкой необходимо проверить состояние фланцев, дефекты должны отсутствовать.

6. При наличии на корпусе арматуры стрелок показывающих направление потока в трубопроводе, при установке следует следовать инструкции, учитывая данное направление при монтаже с трубопроводом. Как правило, такие стрелки можно увидеть на обратных клапанах или шиберах.

7. Болты и другие элементы крепежа затягиваются без сверх усилий, так, как чрезмерная затяжка может привести к образованию трещин на корпусе запорного прибора.

8. Если монтаж запорного элемента производится при помощи сварки, то она осуществляется при открытом положении арматуры.

Кроме этого отметим, что осуществляя монтаж запорной арматуры монтажник должен беречь её от ударов и других повреждений, ведь любые такие эксцессы могут значительно снизить долговечность арматуры.

Читайте так же:

Сравнение арматуры а500с и b500с

Вильчатые цепи

Требования к монтажу - Энциклопедия по машиностроению XXL

Современные требования к монтажу гидравлических приводов (компактность, минимальное число разъемных соединений и элементов арматуры, возможность быстрой разборки и сборки схем с целью устранения отказа или замены аппарата, возможность сборки отдельных гидроаппаратов в компактные функциональные узлы и интегральные блоки и другие), явились основанием для создания гидроаппаратуры модульного исполнения.[c.37]
Расположение гидроагрегатов, как уже указывалось ранее, оказывает решающее влияние на конфигурацию, размеры и форму трубопроводов. Поэтому при монтаже гидроагрегатов необходимо учитывать требования к монтажу трубопроводов.  [c.137]

Основные типы соединений трубопроводов. Требования к монтажу соединений  [c.18]

Соединения трубопроводов должны обеспечивать надежную герметичность их в заданном диапазоне рабочих давлений и температур при повторном демонтаже и монтаже. Полная взаимозаменяемость трубопроводов, изготовленных по эталонам — основное требование к монтажу гидросистем. Подгибка и доводка труб до требуемой конфигурации и длины по месту на каждой машине  [c.22]

ОБЩИЕ ТРЕБОВАНИЯ К МОНТАЖУ ЭЛЕКТРООБОРУДОВАНИЯ  [c.167]

Основные требования к монтажу, наладке и эксплуатации элементов пневмосети  [c. 298]

Общие требования к монтажу любых пневматических устройств можно свести к следующим  [c.298]

Необходимо также учитывать общие условия, влияющие на выбор классов точности или посадок, как, например длина сопрягаемых поверхностей, требования к монтажу и демонтажу, тепловой режим и общие условия эксплуатации, серийность производства, возможность применения калиброванного материала, специфические требования конструкций, технологический процесс изготовления и др.  [c.161]

В этом задании должны быть сформулированы требования к монтажу железобетонных конструкций, обеспечивающие возможность их использования в качестве заземляющих устройств.  [c.108]

Технология изготовления, требования к монтажу  [c.345]

Основные требования к монтажу трубопроводов следующие  [c.302]

Требования к монтажу оборудования РС  [c.106]

Конструктивные требования к монтажу, демонтажу и регулировке подшипников качения  [c. 599]

Установлены требования к монтажу агрегата, условиям его работы, к генератору и двигателю, к комплектовке агрегата запасными частями и инструментом  [c.524]

Монтаж трубопровода горячего водоснабжения и требования к монтажу  [c.449]

Около графических обозначений элементов и устройств указывают номинальные значения их параметров. На свободном поле схемы располагают таблицы, диаграммы, текстовые указания (например, требования к монтажу).  [c.415]

На схемах допускается помещать различные технические данные, характер которых определяется назначением схемы. Такие сведения указывают либо около графических обозначений (по возможности справа или сверху), либо на свободном поле схемы (по возможности над основной надписью). Около графических обозначений элементов и устройств указывают, например, номинальные значения их параметров, а на свободном поле схемы — диаграммы, таблицы, текстовые указания (например, диаграммы последовательности временных процессов, таблицы замыкания контактов коммутирующих устройств, указания о специфических требованиях к монтажу и т. п.).  [c.299]


Технические требования к монтажу и инструкция по эксплуатации эскалатора, наряду с другими сведениями, должны содержать указания по периодич-  [c.266]

Общие требования к импульсным линиям (трубным проводкам) определены 21.19], где указаны стандарты на сортамент труб, изложены правила прокладки трубных проводок,- их испытаний на прочность и плотность, дополнительные требования к монтажу трубных проводок на высокие давления (от 100 до 1000 кгс/см ) и глубокий вакуум. Основные требования, предъявляемые к монтажу трубных проводок теплотехнического контроля на электростанциях, определены также [21.17]. Этой же инструкцией, а также [21.18] установлен порядок приемки трубных проводок из монтажа.  [c.205]

Чертежи монтажные. Монтажный чертеж служит основным документом, по которому осуществляется монтаж изделия на месте его эксплуатации, и должен содержать изображение монтируемого изделия, изображение изделий, применяемых при монтаже, а также полное или частичное изображение устройства (в виде обстановки), на котором осуществляется монтаж изделия, установочные и присоединительные размеры с предельными отклонениями перечень составных частей, необходимых для монтажа технические требования к монтажу изделия.[c.149]

Монтажный чертеж должен содержать изображение монтируемого изделия и предметов, применяемых при монтаже изделия, а также полное или частичное изображение устройства (конструкции фундамента), к которому изделие крепится установочные и присоединительные размеры с предельными отклонениями технические требования к монтажу изделия. Монтируемое изделие изображают на чертеже упрощенно.  [c.166]

Технические условия на изготовление и поставку лифта регламентируют применяемые материалы, требования к технологии и качеству обработки деталей узлов, способ защиты от коррозии, вид поставки заказчику лифта (россыпью, узлами, блоками), комплектность, требования к монтажу.  [c.80]

Монтажный чертеж должен включать технические требования к монтажу данного изделия или его составной части.  [c.139]

Монтажные чертежи [150]. Монтажный чертеж должен содержать 1) изображение монтируемого изделия 2) изображение изделий, применяемых при монтаже, а также полное или частичное изображение устройства (конструкции, фундамента), к которому изделие крепится 3) установочные и присоединительные размеры с предельными отклонениями 4) перечень составных частей, необходимых для монтажа (на первом листе чертёжа над основной надписью) таблица перечня может быть выполнена по форме 1 [149], за исключением граф Формату) и Зонт-, в перечень записывают монтируемое изделие, а также сборочные единицы, детали и материалы, необходимые для монтажа допускается перечень не приводить, но указывать обозначения этих составных частей на полках линий-выносок 5) технические требования к монтажу изделия.[c.433]

Около графических обозначений элементов указывают их буквенно-цифровые позиционные обозначения, а на свободном поле — таблицы, диаграммы, текстовые указания (требования к монтажу и т.п.). Буквенно-цифровое позиционное обозначение состоит цз буквенного обозначения (БО) и порядкового номера, проставленного после БО. БО элементов гидравлических и пневматических схем определяет ГОСТ 2.704-76 [50]. Для обозначений используют заглавные буквы русского алфавита, являющиеся начальными или характерными для наименования элемента. Например, клапан — К, дроссель — ДР (табл. 3.22). Порядковые номера элементам следует присваивать, начиная с единицы, в пределах группы элементов с одинаковым буквенным позицпонным обозначением, например К1, К2, КЗ и т.д. Буквы и цифры в позиционных обозначениях на схеме выполняются шрифтом одного размера. Порядковые номера должны быть присвоены в соответствии с последовательностью расположения элементов или устройств на схеме сверху вниз в направлении слева направо. В тепловых схемах рекомендуется присваивать порядковые номера в зависимости от направления движения рабочей среды в пределах каждого контура.  [c.83]


Монтажный чертеж Должен содержать контурное или упрощенное изображение изделия или его части, установочные или присоединительные размеры, угловую спецификацию, технические требования к монтажу изделия и контуры пограничного изделпя, на которое производится ьюнтаж.  [c.321]

Требования к монтажу. Монтаж торцового уплотнения является ответственной операцией. Например, в насосах после установки торцового уплотнения выполняют сборку протрчной части насоса, подсоединяют всасывающий и нагнетательный трубопроводы, системы вспомогательных трубопроводов и проводят опробование насоса. Неудачная сборка торцового уплотнения неизбежно приводит к полному демонтажу насоса.  [c.350]

Следует отметить, что при выборе посадок на основе примеров применения недостаточно исходит только из аналогии, которая может оказаться неполной. Необходимо также учитывать общие условия, влияющие на выбор квалитетов или посадок, как, например, длина сопрягаемых поверхностей, требования к монтажу и демонтажу, тепловой режим и общие условия эксплуатации, серийность производства и возможность применения калиброванного материала, специфические требования конструкций, техт нологический процесс изготовления и др. Влияние некоторых общих факторов на выбор посадок рекомендуется учитывать согласно табл. 1.95.  [c.301]

Работы по монтажу технологических трубопроводов производятся в соответствии с главой СНиП П1-Г.9-62, в которой. приводятся основные положения и требования к монтажу технологических трубопроводов (практически из любых материалов), работающих под давлением до 700 кгс1см .  [c.172]


Руководство по

: Требования для установки - MediaWiki

Помимо самого программного обеспечения, стандартная установка MediaWiki имеет следующие требования:

  • Веб-сервер необходим для обслуживания запрошенных страниц в клиентском браузере.
  • Для запуска программного обеспечения требуется
  • PHP.
  • Сервер базы данных необходим для хранения страниц и данных сайта.

Кроме того, существуют различные дополнительные зависимости, которые требуются, если вы хотите использовать определенные расширенные функции (см. Ниже).

Если ваш веб-сайт размещен (т.е. у вас нет прямого контроля над ним), обратитесь к администратору сервера или в хостинговую компанию, чтобы убедиться, что эти программные пакеты установлены и доступны.

Простая установка с одной загрузкой

Если вы используете Linux, лучше всего установить apache, php и MariaDB с помощью диспетчера пакетов. В Debian и Ubuntu сделайте следующее:

 sudo apt-get install php php-apcu php-intl php-mbstring php-xml php-mysql mariadb-server apache2
 

В других операционных системах используйте XAMPP с https: // www.apachefriends.org для установки и настройки всех важных пакетов - веб-сервера Apache, PHP и MariaDB - всего за одну загрузку. Он доступен для Linux, Windows, Mac и Solaris. По состоянию на январь 2021 года последняя версия XAMPP включает PHP 8.0 (для MediaWiki требуется как минимум 7.3.19).

В качестве альтернативы, если у вас есть компьютер Apple, вы можете использовать MAMP, который является эквивалентом XAMPP. В настоящее время MAMP включает возможность запуска веб-сервера Apache и базы данных MySQL. Он доступен как для Windows, так и для Mac, но обычно используется на Mac вместо Windows.В настоящее время он использует последние версии PHP и MySQL.

Веб-сервер

Для обслуживания вики-страниц в браузерах MediaWiki требуется некоторое программное обеспечение веб-сервера. Часто у вас не будет выбора, какое программное обеспечение использовать - оно будет предоставлено вашим хостинг-провайдером.

В большинстве установок используется веб-сервер Apache, доступный на официальной странице загрузки. Однако MediaWiki также была протестирована в IIS 7.0, Cherokee, Hiawatha, LiteSpeed, nginx (пример конфигурации), lighttpd и Caddy.

PHP

MediaWiki несовместима с PHP 7.4.0–7.4.2 из-за ошибки восходящего потока. Вместо этого используйте PHP 7.4.3 или новее. Дополнительную информацию см. В задаче T246594.

PHP - это язык программирования, на котором написана MediaWiki, и он необходим для работы программного обеспечения.

Обратите внимание, что хотя MediaWiki поставляется со сценарием установки, который обеспечивает конфигурацию наиболее важных элементов через Интернет, для более подробной настройки требуются некоторые знания PHP.

  • Для последней стабильной версии MediaWiki требуется не менее PHP 7.3.19 . См. Страницу о совместимости для получения дополнительной информации.
  • Требуются следующие расширения:
  • Обратите внимание, что все они включены в PHP по умолчанию.
  • Программа установки
  • MediaWiki выдаст предупреждение, если у вас нет дополнительного расширения PHP intl «для обработки нормализации Unicode».
    • В большинстве дистрибутивов на основе Debian / Ubuntu это пакет php-intl.
  • Также рекомендуется расширение
  • PHP OpenSSL. См. Руководство: $ wgSessionInsecureSecrets.
  • В большинстве дистрибутивов на основе Debian / Ubuntu требуется пакет php-mysql, если вы хотите, чтобы MediaWiki использовала MySQL.
  • Для некоторых функций MediaWiki могут потребоваться функции PHP, выполняющие внешние процессы, такие как создание эскизов изображений, которые обычно отключаются некоторыми дешевыми хостами. Это особенно заметно в MediaWiki 1.23 при загрузке файлов (задача T68467). Пожалуйста, примите это во внимание, если вы планируете установить MediaWiki на общем хосте.
  • Для расширений
  • MediaWiki могут потребоваться дополнительные функции PHP, например VisualEditor требует поддержки libcurl (php-curl в дистрибутивах на основе Debian / Ubuntu).

Если вам нужно скомпилировать PHP из исходного кода, см. Конфигурацию PHP для параметров компиляции, которые влияют на MediaWiki.

  • Для некоторых серверов также может потребоваться установка эквивалентного модуля базы данных и модуля управления сеансом. Дополнительную информацию см. В отдельных инструкциях к операционной системе.
  • При установке в Windows с помощью установщика Microsoft добавьте расширение для вашей базы данных по выбору (MySQL / MariaDB или Postgres) к устанавливаемым функциям.

Сервер базы данных

Предупреждение: Поддержка Oracle и Microsoft SQL Server не поддерживается и была исключена в MediaWiki 1.34. Вам настоятельно не рекомендуется их использовать.


MediaWiki хранит весь текст и данные (страницы содержимого, сведения о пользователях, системные сообщения и т. Д.) В базе данных, которую он может использовать совместно с другими веб-приложениями (phpBB и т. Д.). Для запуска последней версии MediaWiki вам понадобится , один из из следующих серверов баз данных:

Поддерживался в прошлом, в настоящее время не поддерживается:

  • Oracle (не поддерживается в последних версиях MediaWiki из-за открытых ошибок блокировки)
  • Microsoft SQL Server 2008 R2 или более поздней версии поддерживается для выпусков LTS и не гарантируется работа для выпусков, отличных от LTS (требуется Microsoft Windows в качестве операционной системы, поскольку он использует драйвер SQLSRV).

Убедитесь, что установлен полнотекстовый модуль.

Некоторые пользователи считают полезным установить дополнительный программный пакет, такой как phpMyAdmin (MySQL / MariaDB) или phpPgAdmin (Postgres), для помощи в администрировании сервера базы данных.

MySQL 5 требуется начиная с MediaWiki 1.19. MySQL 4 требовался начиная с MediaWiki 1.6. (Если вы используете старую версию MySQL и не можете выполнить обновление, вам необходимо использовать MediaWiki 1.5.8, но эта версия не поддерживается.)

Требования к оборудованию

Рекомендуемые минимальные требования: 256 МБ ОЗУ для веб-сайта на одном компьютере и 85 МБ хранилища, хотя этого недостаточно для загруженного общедоступного сайта или сайта с включенной загрузкой.Некоторые пользователи сообщают, что MediaWiki запускается на компьютерах с объемом оперативной памяти всего 48 МБ.

Размер установки может быть уменьшен примерно до 50 МБ для установки разработчика и примерно до 26 МБ для установки конечного пользователя, не являющейся разработчиком. См. Руководство: Уменьшение размера установки.

Необязательные зависимости

Другое программное обеспечение [править]

  • Для создания эскизов изображений требуется ImageMagick или GD .
  • TeX требуется для встроенного отображения математических формул.В большинстве дистрибутивов на основе Debian / Ubuntu это пакет texlive .
  • Sendmail требуется для того, чтобы система могла отправлять электронные письма.
  • Доступ к оболочке требуется для запуска сценариев обслуживания; без него обновление MediaWiki может быть затруднено.
  • GNU diff3 может быть предоставлен для автоматического разрешения конфликтов.

Для получения дополнительной информации о вышеупомянутых элементах см. Руководство: Установка сторонних инструментов.

VisualEditor [править]

В MediaWiki версии 1.34 и более ранних для расширения VisualEditor (а также для расширения StructuredDiscussions (старый Flow)) требовался веб-сервис Parsoid, который был реализован с использованием Node. js. Node.js не предоставляется большинством компаний, предоставляющих общий хостинг (HostGator, Bluehost, Dreamhost и т. Д.). По соображениям производительности и безопасности лучше использовать решение для выделенного хостинга, такое как виртуальный частный сервер («VPS»).

Scribunto [править]

Если вы хотите вызывать модули Lua (см. Их на этой вики) со страниц и шаблонов вики, для вашей вики также потребуется Scribunto.

См. Также [править]

  • Совместимость, для получения информации о том, как требования к установке MediaWiki могут измениться в будущем.
Пакеты программного обеспечения

Руководство: Требования к установке - MediaWiki

Помимо самого программного обеспечения, стандартная установка MediaWiki имеет следующие требования:

  • Веб-сервер необходим для обслуживания запрошенных страниц в клиентском браузере.
  • Для запуска программного обеспечения требуется
  • PHP.
  • Сервер базы данных необходим для хранения страниц и данных сайта.

Кроме того, существуют различные дополнительные зависимости, которые требуются, если вы хотите использовать определенные расширенные функции (см. Ниже).

Если ваш веб-сайт размещен (т.е. у вас нет прямого контроля над ним), обратитесь к администратору сервера или в хостинговую компанию, чтобы убедиться, что эти программные пакеты установлены и доступны.

Простая установка с одной загрузкой

Если вы используете Linux, лучше всего установить apache, php и MariaDB с помощью диспетчера пакетов.В Debian и Ubuntu сделайте следующее:

 sudo apt-get install php php-apcu php-intl php-mbstring php-xml php-mysql mariadb-server apache2
 

В других операционных системах используйте XAMPP с https://www.apachefriends.org для установки и настройки всех важных пакетов - веб-сервера Apache, PHP и MariaDB - с помощью только одной загрузки. Он доступен для Linux, Windows, Mac и Solaris. По состоянию на январь 2021 года последняя версия XAMPP включает PHP 8. 0 (для MediaWiki требуется как минимум 7.3.19).

В качестве альтернативы, если у вас есть компьютер Apple, вы можете использовать MAMP, который является эквивалентом XAMPP. В настоящее время MAMP включает возможность запуска веб-сервера Apache и базы данных MySQL. Он доступен как для Windows, так и для Mac, но обычно используется на Mac вместо Windows. В настоящее время он использует последние версии PHP и MySQL.

Веб-сервер

Для обслуживания вики-страниц в браузерах MediaWiki требуется некоторое программное обеспечение веб-сервера. Часто у вас не будет выбора, какое программное обеспечение использовать - оно будет предоставлено вашим хостинг-провайдером.

В большинстве установок используется веб-сервер Apache, доступный на официальной странице загрузки. Однако MediaWiki также была протестирована в IIS 7.0, Cherokee, Hiawatha, LiteSpeed, nginx (пример конфигурации), lighttpd и Caddy.

PHP

MediaWiki несовместима с PHP 7.4.0–7. 4.2 из-за ошибки восходящего потока. Вместо этого используйте PHP 7.4.3 или новее. Дополнительную информацию см. В задаче T246594.

PHP - это язык программирования, на котором написана MediaWiki, и он необходим для работы программного обеспечения.

Обратите внимание, что хотя MediaWiki поставляется со сценарием установки, который обеспечивает конфигурацию наиболее важных элементов через Интернет, для более подробной настройки требуются некоторые знания PHP.

  • Для последней стабильной версии MediaWiki требуется не менее PHP 7.3.19 . См. Страницу о совместимости для получения дополнительной информации.
  • Требуются следующие расширения:
  • Обратите внимание, что все они включены в PHP по умолчанию.
  • Программа установки
  • MediaWiki выдаст предупреждение, если у вас нет дополнительного расширения PHP intl «для обработки нормализации Unicode».
    • В большинстве дистрибутивов на основе Debian / Ubuntu это пакет php-intl.
  • Также рекомендуется расширение
  • PHP OpenSSL. См. Руководство: $ wgSessionInsecureSecrets.
  • В большинстве дистрибутивов на основе Debian / Ubuntu требуется пакет php-mysql, если вы хотите, чтобы MediaWiki использовала MySQL.
  • Для некоторых функций MediaWiki могут потребоваться функции PHP, выполняющие внешние процессы, такие как создание эскизов изображений, которые обычно отключаются некоторыми дешевыми хостами.Это особенно заметно в MediaWiki 1.23 при загрузке файлов (задача T68467). Пожалуйста, примите это во внимание, если вы планируете установить MediaWiki на общем хосте.
  • Для расширений
  • MediaWiki могут потребоваться дополнительные функции PHP, например VisualEditor требует поддержки libcurl (php-curl в дистрибутивах на основе Debian / Ubuntu).

Если вам нужно скомпилировать PHP из исходного кода, см. Конфигурацию PHP для параметров компиляции, которые влияют на MediaWiki.

  • Для некоторых серверов также может потребоваться установка эквивалентного модуля базы данных и модуля управления сеансом.Дополнительную информацию см. В отдельных инструкциях к операционной системе.
  • При установке в Windows с помощью установщика Microsoft добавьте расширение для вашей базы данных по выбору (MySQL / MariaDB или Postgres) к устанавливаемым функциям.

Сервер базы данных

Предупреждение: Поддержка Oracle и Microsoft SQL Server не поддерживается и была исключена в MediaWiki 1.34. Вам настоятельно не рекомендуется их использовать.


MediaWiki хранит весь текст и данные (страницы содержимого, сведения о пользователях, системные сообщения и т. Д.) В базе данных, которую он может использовать совместно с другими веб-приложениями (phpBB и т. Д.). Для запуска последней версии MediaWiki вам понадобится , один из из следующих серверов баз данных:

Поддерживался в прошлом, в настоящее время не поддерживается:

  • Oracle (не поддерживается в последних версиях MediaWiki из-за открытых ошибок блокировки)
  • Microsoft SQL Server 2008 R2 или более поздней версии поддерживается для выпусков LTS и не гарантируется работа для выпусков, отличных от LTS (требуется Microsoft Windows в качестве операционной системы, поскольку он использует драйвер SQLSRV).

Убедитесь, что установлен полнотекстовый модуль.

Некоторые пользователи считают полезным установить дополнительный программный пакет, такой как phpMyAdmin (MySQL / MariaDB) или phpPgAdmin (Postgres), для помощи в администрировании сервера базы данных.

MySQL 5 требуется начиная с MediaWiki 1.19. MySQL 4 требовался начиная с MediaWiki 1.6. (Если вы используете старую версию MySQL и не можете выполнить обновление, вам необходимо использовать MediaWiki 1.5.8, но эта версия не поддерживается.)

Требования к оборудованию

Рекомендуемые минимальные требования: 256 МБ ОЗУ для веб-сайта на одном компьютере и 85 МБ хранилища, хотя этого недостаточно для загруженного общедоступного сайта или сайта с включенной загрузкой.Некоторые пользователи сообщают, что MediaWiki запускается на компьютерах с объемом оперативной памяти всего 48 МБ.

Размер установки может быть уменьшен примерно до 50 МБ для установки разработчика и примерно до 26 МБ для установки конечного пользователя, не являющейся разработчиком. См. Руководство: Уменьшение размера установки.

Необязательные зависимости

Другое программное обеспечение [править]

  • Для создания эскизов изображений требуется ImageMagick или GD .
  • TeX требуется для встроенного отображения математических формул.В большинстве дистрибутивов на основе Debian / Ubuntu это пакет texlive .
  • Sendmail требуется для того, чтобы система могла отправлять электронные письма.
  • Доступ к оболочке требуется для запуска сценариев обслуживания; без него обновление MediaWiki может быть затруднено.
  • GNU diff3 может быть предоставлен для автоматического разрешения конфликтов.

Для получения дополнительной информации о вышеупомянутых элементах см. Руководство: Установка сторонних инструментов.

VisualEditor [править]

В MediaWiki версии 1.34 и более ранних для расширения VisualEditor (а также для расширения StructuredDiscussions (старый Flow)) требовался веб-сервис Parsoid, который был реализован с использованием Node.js. Node.js не предоставляется большинством компаний, предоставляющих общий хостинг (HostGator, Bluehost, Dreamhost и т. Д.). По соображениям производительности и безопасности лучше использовать решение для выделенного хостинга, такое как виртуальный частный сервер («VPS»).

Scribunto [править]

Если вы хотите вызывать модули Lua (см. Их на этой вики) со страниц и шаблонов вики, для вашей вики также потребуется Scribunto.

См. Также [править]

  • Совместимость, для получения информации о том, как требования к установке MediaWiki могут измениться в будущем.
Пакеты программного обеспечения

Руководство: Требования к установке - MediaWiki

Помимо самого программного обеспечения, стандартная установка MediaWiki имеет следующие требования:

  • Веб-сервер необходим для обслуживания запрошенных страниц в клиентском браузере.
  • Для запуска программного обеспечения требуется
  • PHP.
  • Сервер базы данных необходим для хранения страниц и данных сайта.

Кроме того, существуют различные дополнительные зависимости, которые требуются, если вы хотите использовать определенные расширенные функции (см. Ниже).

Если ваш веб-сайт размещен (т.е. у вас нет прямого контроля над ним), обратитесь к администратору сервера или в хостинговую компанию, чтобы убедиться, что эти программные пакеты установлены и доступны.

Простая установка с одной загрузкой

Если вы используете Linux, лучше всего установить apache, php и MariaDB с помощью диспетчера пакетов.В Debian и Ubuntu сделайте следующее:

 sudo apt-get install php php-apcu php-intl php-mbstring php-xml php-mysql mariadb-server apache2
 

В других операционных системах используйте XAMPP с https://www.apachefriends.org для установки и настройки всех важных пакетов - веб-сервера Apache, PHP и MariaDB - с помощью только одной загрузки. Он доступен для Linux, Windows, Mac и Solaris. По состоянию на январь 2021 года последняя версия XAMPP включает PHP 8.0 (для MediaWiki требуется как минимум 7.3.19).

В качестве альтернативы, если у вас есть компьютер Apple, вы можете использовать MAMP, который является эквивалентом XAMPP. В настоящее время MAMP включает возможность запуска веб-сервера Apache и базы данных MySQL. Он доступен как для Windows, так и для Mac, но обычно используется на Mac вместо Windows. В настоящее время он использует последние версии PHP и MySQL.

Веб-сервер

Для обслуживания вики-страниц в браузерах MediaWiki требуется некоторое программное обеспечение веб-сервера. Часто у вас не будет выбора, какое программное обеспечение использовать - оно будет предоставлено вашим хостинг-провайдером.

В большинстве установок используется веб-сервер Apache, доступный на официальной странице загрузки. Однако MediaWiki также была протестирована в IIS 7.0, Cherokee, Hiawatha, LiteSpeed, nginx (пример конфигурации), lighttpd и Caddy.

PHP

MediaWiki несовместима с PHP 7.4.0–7.4.2 из-за ошибки восходящего потока. Вместо этого используйте PHP 7.4.3 или новее. Дополнительную информацию см. В задаче T246594.

PHP - это язык программирования, на котором написана MediaWiki, и он необходим для работы программного обеспечения.

Обратите внимание, что хотя MediaWiki поставляется со сценарием установки, который обеспечивает конфигурацию наиболее важных элементов через Интернет, для более подробной настройки требуются некоторые знания PHP.

  • Для последней стабильной версии MediaWiki требуется не менее PHP 7.3.19 . См. Страницу о совместимости для получения дополнительной информации.
  • Требуются следующие расширения:
  • Обратите внимание, что все они включены в PHP по умолчанию.
  • Программа установки
  • MediaWiki выдаст предупреждение, если у вас нет дополнительного расширения PHP intl «для обработки нормализации Unicode».
    • В большинстве дистрибутивов на основе Debian / Ubuntu это пакет php-intl.
  • Также рекомендуется расширение
  • PHP OpenSSL. См. Руководство: $ wgSessionInsecureSecrets.
  • В большинстве дистрибутивов на основе Debian / Ubuntu требуется пакет php-mysql, если вы хотите, чтобы MediaWiki использовала MySQL.
  • Для некоторых функций MediaWiki могут потребоваться функции PHP, выполняющие внешние процессы, такие как создание эскизов изображений, которые обычно отключаются некоторыми дешевыми хостами.Это особенно заметно в MediaWiki 1.23 при загрузке файлов (задача T68467). Пожалуйста, примите это во внимание, если вы планируете установить MediaWiki на общем хосте.
  • Для расширений
  • MediaWiki могут потребоваться дополнительные функции PHP, например VisualEditor требует поддержки libcurl (php-curl в дистрибутивах на основе Debian / Ubuntu).

Если вам нужно скомпилировать PHP из исходного кода, см. Конфигурацию PHP для параметров компиляции, которые влияют на MediaWiki.

  • Для некоторых серверов также может потребоваться установка эквивалентного модуля базы данных и модуля управления сеансом.Дополнительную информацию см. В отдельных инструкциях к операционной системе.
  • При установке в Windows с помощью установщика Microsoft добавьте расширение для вашей базы данных по выбору (MySQL / MariaDB или Postgres) к устанавливаемым функциям.

Сервер базы данных

Предупреждение: Поддержка Oracle и Microsoft SQL Server не поддерживается и была исключена в MediaWiki 1.34. Вам настоятельно не рекомендуется их использовать.


MediaWiki хранит весь текст и данные (страницы содержимого, сведения о пользователях, системные сообщения и т. Д.) В базе данных, которую он может использовать совместно с другими веб-приложениями (phpBB и т. Д.). Для запуска последней версии MediaWiki вам понадобится , один из из следующих серверов баз данных:

Поддерживался в прошлом, в настоящее время не поддерживается:

  • Oracle (не поддерживается в последних версиях MediaWiki из-за открытых ошибок блокировки)
  • Microsoft SQL Server 2008 R2 или более поздней версии поддерживается для выпусков LTS и не гарантируется работа для выпусков, отличных от LTS (требуется Microsoft Windows в качестве операционной системы, поскольку он использует драйвер SQLSRV).

Убедитесь, что установлен полнотекстовый модуль.

Некоторые пользователи считают полезным установить дополнительный программный пакет, такой как phpMyAdmin (MySQL / MariaDB) или phpPgAdmin (Postgres), для помощи в администрировании сервера базы данных.

MySQL 5 требуется начиная с MediaWiki 1.19. MySQL 4 требовался начиная с MediaWiki 1.6. (Если вы используете старую версию MySQL и не можете выполнить обновление, вам необходимо использовать MediaWiki 1.5.8, но эта версия не поддерживается.)

Требования к оборудованию

Рекомендуемые минимальные требования: 256 МБ ОЗУ для веб-сайта на одном компьютере и 85 МБ хранилища, хотя этого недостаточно для загруженного общедоступного сайта или сайта с включенной загрузкой.Некоторые пользователи сообщают, что MediaWiki запускается на компьютерах с объемом оперативной памяти всего 48 МБ.

Размер установки может быть уменьшен примерно до 50 МБ для установки разработчика и примерно до 26 МБ для установки конечного пользователя, не являющейся разработчиком. См. Руководство: Уменьшение размера установки.

Необязательные зависимости

Другое программное обеспечение [править]

  • Для создания эскизов изображений требуется ImageMagick или GD .
  • TeX требуется для встроенного отображения математических формул.В большинстве дистрибутивов на основе Debian / Ubuntu это пакет texlive .
  • Sendmail требуется для того, чтобы система могла отправлять электронные письма.
  • Доступ к оболочке требуется для запуска сценариев обслуживания; без него обновление MediaWiki может быть затруднено.
  • GNU diff3 может быть предоставлен для автоматического разрешения конфликтов.

Для получения дополнительной информации о вышеупомянутых элементах см. Руководство: Установка сторонних инструментов.

VisualEditor [править]

В MediaWiki версии 1.34 и более ранних для расширения VisualEditor (а также для расширения StructuredDiscussions (старый Flow)) требовался веб-сервис Parsoid, который был реализован с использованием Node.js. Node.js не предоставляется большинством компаний, предоставляющих общий хостинг (HostGator, Bluehost, Dreamhost и т. Д.). По соображениям производительности и безопасности лучше использовать решение для выделенного хостинга, такое как виртуальный частный сервер («VPS»).

Scribunto [править]

Если вы хотите вызывать модули Lua (см. Их на этой вики) со страниц и шаблонов вики, для вашей вики также потребуется Scribunto.

См. Также [править]

  • Совместимость, для получения информации о том, как требования к установке MediaWiki могут измениться в будущем.
Пакеты программного обеспечения

Руководство: Требования к установке - MediaWiki

Помимо самого программного обеспечения, стандартная установка MediaWiki имеет следующие требования:

  • Веб-сервер необходим для обслуживания запрошенных страниц в клиентском браузере.
  • Для запуска программного обеспечения требуется
  • PHP.
  • Сервер базы данных необходим для хранения страниц и данных сайта.

Кроме того, существуют различные дополнительные зависимости, которые требуются, если вы хотите использовать определенные расширенные функции (см. Ниже).

Если ваш веб-сайт размещен (т.е. у вас нет прямого контроля над ним), обратитесь к администратору сервера или в хостинговую компанию, чтобы убедиться, что эти программные пакеты установлены и доступны.

Простая установка с одной загрузкой

Если вы используете Linux, лучше всего установить apache, php и MariaDB с помощью диспетчера пакетов.В Debian и Ubuntu сделайте следующее:

 sudo apt-get install php php-apcu php-intl php-mbstring php-xml php-mysql mariadb-server apache2
 

В других операционных системах используйте XAMPP с https://www.apachefriends.org для установки и настройки всех важных пакетов - веб-сервера Apache, PHP и MariaDB - с помощью только одной загрузки. Он доступен для Linux, Windows, Mac и Solaris. По состоянию на январь 2021 года последняя версия XAMPP включает PHP 8.0 (для MediaWiki требуется как минимум 7.3.19).

В качестве альтернативы, если у вас есть компьютер Apple, вы можете использовать MAMP, который является эквивалентом XAMPP. В настоящее время MAMP включает возможность запуска веб-сервера Apache и базы данных MySQL. Он доступен как для Windows, так и для Mac, но обычно используется на Mac вместо Windows. В настоящее время он использует последние версии PHP и MySQL.

Веб-сервер

Для обслуживания вики-страниц в браузерах MediaWiki требуется некоторое программное обеспечение веб-сервера. Часто у вас не будет выбора, какое программное обеспечение использовать - оно будет предоставлено вашим хостинг-провайдером.

В большинстве установок используется веб-сервер Apache, доступный на официальной странице загрузки. Однако MediaWiki также была протестирована в IIS 7.0, Cherokee, Hiawatha, LiteSpeed, nginx (пример конфигурации), lighttpd и Caddy.

PHP

MediaWiki несовместима с PHP 7.4.0–7.4.2 из-за ошибки восходящего потока. Вместо этого используйте PHP 7.4.3 или новее. Дополнительную информацию см. В задаче T246594.

PHP - это язык программирования, на котором написана MediaWiki, и он необходим для работы программного обеспечения.

Обратите внимание, что хотя MediaWiki поставляется со сценарием установки, который обеспечивает конфигурацию наиболее важных элементов через Интернет, для более подробной настройки требуются некоторые знания PHP.

  • Для последней стабильной версии MediaWiki требуется не менее PHP 7.3.19 . См. Страницу о совместимости для получения дополнительной информации.
  • Требуются следующие расширения:
  • Обратите внимание, что все они включены в PHP по умолчанию.
  • Программа установки
  • MediaWiki выдаст предупреждение, если у вас нет дополнительного расширения PHP intl «для обработки нормализации Unicode».
    • В большинстве дистрибутивов на основе Debian / Ubuntu это пакет php-intl.
  • Также рекомендуется расширение
  • PHP OpenSSL. См. Руководство: $ wgSessionInsecureSecrets.
  • В большинстве дистрибутивов на основе Debian / Ubuntu требуется пакет php-mysql, если вы хотите, чтобы MediaWiki использовала MySQL.
  • Для некоторых функций MediaWiki могут потребоваться функции PHP, выполняющие внешние процессы, такие как создание эскизов изображений, которые обычно отключаются некоторыми дешевыми хостами.Это особенно заметно в MediaWiki 1.23 при загрузке файлов (задача T68467). Пожалуйста, примите это во внимание, если вы планируете установить MediaWiki на общем хосте.
  • Для расширений
  • MediaWiki могут потребоваться дополнительные функции PHP, например VisualEditor требует поддержки libcurl (php-curl в дистрибутивах на основе Debian / Ubuntu).

Если вам нужно скомпилировать PHP из исходного кода, см. Конфигурацию PHP для параметров компиляции, которые влияют на MediaWiki.

  • Для некоторых серверов также может потребоваться установка эквивалентного модуля базы данных и модуля управления сеансом.Дополнительную информацию см. В отдельных инструкциях к операционной системе.
  • При установке в Windows с помощью установщика Microsoft добавьте расширение для вашей базы данных по выбору (MySQL / MariaDB или Postgres) к устанавливаемым функциям.

Сервер базы данных

Предупреждение: Поддержка Oracle и Microsoft SQL Server не поддерживается и была исключена в MediaWiki 1.34. Вам настоятельно не рекомендуется их использовать.


MediaWiki хранит весь текст и данные (страницы содержимого, сведения о пользователях, системные сообщения и т. Д.) В базе данных, которую он может использовать совместно с другими веб-приложениями (phpBB и т. Д.). Для запуска последней версии MediaWiki вам понадобится , один из из следующих серверов баз данных:

Поддерживался в прошлом, в настоящее время не поддерживается:

  • Oracle (не поддерживается в последних версиях MediaWiki из-за открытых ошибок блокировки)
  • Microsoft SQL Server 2008 R2 или более поздней версии поддерживается для выпусков LTS и не гарантируется работа для выпусков, отличных от LTS (требуется Microsoft Windows в качестве операционной системы, поскольку он использует драйвер SQLSRV).

Убедитесь, что установлен полнотекстовый модуль.

Некоторые пользователи считают полезным установить дополнительный программный пакет, такой как phpMyAdmin (MySQL / MariaDB) или phpPgAdmin (Postgres), для помощи в администрировании сервера базы данных.

MySQL 5 требуется начиная с MediaWiki 1.19. MySQL 4 требовался начиная с MediaWiki 1.6. (Если вы используете старую версию MySQL и не можете выполнить обновление, вам необходимо использовать MediaWiki 1.5.8, но эта версия не поддерживается.)

Требования к оборудованию

Рекомендуемые минимальные требования: 256 МБ ОЗУ для веб-сайта на одном компьютере и 85 МБ хранилища, хотя этого недостаточно для загруженного общедоступного сайта или сайта с включенной загрузкой.Некоторые пользователи сообщают, что MediaWiki запускается на компьютерах с объемом оперативной памяти всего 48 МБ.

Размер установки может быть уменьшен примерно до 50 МБ для установки разработчика и примерно до 26 МБ для установки конечного пользователя, не являющейся разработчиком. См. Руководство: Уменьшение размера установки.

Необязательные зависимости

Другое программное обеспечение [править]

  • Для создания эскизов изображений требуется ImageMagick или GD .
  • TeX требуется для встроенного отображения математических формул.В большинстве дистрибутивов на основе Debian / Ubuntu это пакет texlive .
  • Sendmail требуется для того, чтобы система могла отправлять электронные письма.
  • Доступ к оболочке требуется для запуска сценариев обслуживания; без него обновление MediaWiki может быть затруднено.
  • GNU diff3 может быть предоставлен для автоматического разрешения конфликтов.

Для получения дополнительной информации о вышеупомянутых элементах см. Руководство: Установка сторонних инструментов.

VisualEditor [править]

В MediaWiki версии 1.34 и более ранних для расширения VisualEditor (а также для расширения StructuredDiscussions (старый Flow)) требовался веб-сервис Parsoid, который был реализован с использованием Node.js. Node.js не предоставляется большинством компаний, предоставляющих общий хостинг (HostGator, Bluehost, Dreamhost и т. Д.). По соображениям производительности и безопасности лучше использовать решение для выделенного хостинга, такое как виртуальный частный сервер («VPS»).

Scribunto [править]

Если вы хотите вызывать модули Lua (см. Их на этой вики) со страниц и шаблонов вики, для вашей вики также потребуется Scribunto.

См. Также [править]

  • Совместимость, для получения информации о том, как требования к установке MediaWiki могут измениться в будущем.
Пакеты программного обеспечения

Руководство: Требования к установке - MediaWiki

Помимо самого программного обеспечения, стандартная установка MediaWiki имеет следующие требования:

  • Веб-сервер необходим для обслуживания запрошенных страниц в клиентском браузере.
  • Для запуска программного обеспечения требуется
  • PHP.
  • Сервер базы данных необходим для хранения страниц и данных сайта.

Кроме того, существуют различные дополнительные зависимости, которые требуются, если вы хотите использовать определенные расширенные функции (см. Ниже).

Если ваш веб-сайт размещен (т.е. у вас нет прямого контроля над ним), обратитесь к администратору сервера или в хостинговую компанию, чтобы убедиться, что эти программные пакеты установлены и доступны.

Простая установка с одной загрузкой

Если вы используете Linux, лучше всего установить apache, php и MariaDB с помощью диспетчера пакетов.В Debian и Ubuntu сделайте следующее:

 sudo apt-get install php php-apcu php-intl php-mbstring php-xml php-mysql mariadb-server apache2
 

В других операционных системах используйте XAMPP с https://www.apachefriends.org для установки и настройки всех важных пакетов - веб-сервера Apache, PHP и MariaDB - с помощью только одной загрузки. Он доступен для Linux, Windows, Mac и Solaris. По состоянию на январь 2021 года последняя версия XAMPP включает PHP 8.0 (для MediaWiki требуется как минимум 7.3.19).

В качестве альтернативы, если у вас есть компьютер Apple, вы можете использовать MAMP, который является эквивалентом XAMPP. В настоящее время MAMP включает возможность запуска веб-сервера Apache и базы данных MySQL. Он доступен как для Windows, так и для Mac, но обычно используется на Mac вместо Windows. В настоящее время он использует последние версии PHP и MySQL.

Веб-сервер

Для обслуживания вики-страниц в браузерах MediaWiki требуется некоторое программное обеспечение веб-сервера. Часто у вас не будет выбора, какое программное обеспечение использовать - оно будет предоставлено вашим хостинг-провайдером.

В большинстве установок используется веб-сервер Apache, доступный на официальной странице загрузки. Однако MediaWiki также была протестирована в IIS 7.0, Cherokee, Hiawatha, LiteSpeed, nginx (пример конфигурации), lighttpd и Caddy.

PHP

MediaWiki несовместима с PHP 7.4.0–7.4.2 из-за ошибки восходящего потока. Вместо этого используйте PHP 7.4.3 или новее. Дополнительную информацию см. В задаче T246594.

PHP - это язык программирования, на котором написана MediaWiki, и он необходим для работы программного обеспечения.

Обратите внимание, что хотя MediaWiki поставляется со сценарием установки, который обеспечивает конфигурацию наиболее важных элементов через Интернет, для более подробной настройки требуются некоторые знания PHP.

  • Для последней стабильной версии MediaWiki требуется не менее PHP 7.3.19 . См. Страницу о совместимости для получения дополнительной информации.
  • Требуются следующие расширения:
  • Обратите внимание, что все они включены в PHP по умолчанию.
  • Программа установки
  • MediaWiki выдаст предупреждение, если у вас нет дополнительного расширения PHP intl «для обработки нормализации Unicode».
    • В большинстве дистрибутивов на основе Debian / Ubuntu это пакет php-intl.
  • Также рекомендуется расширение
  • PHP OpenSSL. См. Руководство: $ wgSessionInsecureSecrets.
  • В большинстве дистрибутивов на основе Debian / Ubuntu требуется пакет php-mysql, если вы хотите, чтобы MediaWiki использовала MySQL.
  • Для некоторых функций MediaWiki могут потребоваться функции PHP, выполняющие внешние процессы, такие как создание эскизов изображений, которые обычно отключаются некоторыми дешевыми хостами.Это особенно заметно в MediaWiki 1.23 при загрузке файлов (задача T68467). Пожалуйста, примите это во внимание, если вы планируете установить MediaWiki на общем хосте.
  • Для расширений
  • MediaWiki могут потребоваться дополнительные функции PHP, например VisualEditor требует поддержки libcurl (php-curl в дистрибутивах на основе Debian / Ubuntu).

Если вам нужно скомпилировать PHP из исходного кода, см. Конфигурацию PHP для параметров компиляции, которые влияют на MediaWiki.

  • Для некоторых серверов также может потребоваться установка эквивалентного модуля базы данных и модуля управления сеансом.Дополнительную информацию см. В отдельных инструкциях к операционной системе.
  • При установке в Windows с помощью установщика Microsoft добавьте расширение для вашей базы данных по выбору (MySQL / MariaDB или Postgres) к устанавливаемым функциям.

Сервер базы данных

Предупреждение: Поддержка Oracle и Microsoft SQL Server не поддерживается и была исключена в MediaWiki 1.34. Вам настоятельно не рекомендуется их использовать.


MediaWiki хранит весь текст и данные (страницы содержимого, сведения о пользователях, системные сообщения и т. Д.) В базе данных, которую он может использовать совместно с другими веб-приложениями (phpBB и т. Д.). Для запуска последней версии MediaWiki вам понадобится , один из из следующих серверов баз данных:

Поддерживался в прошлом, в настоящее время не поддерживается:

  • Oracle (не поддерживается в последних версиях MediaWiki из-за открытых ошибок блокировки)
  • Microsoft SQL Server 2008 R2 или более поздней версии поддерживается для выпусков LTS и не гарантируется работа для выпусков, отличных от LTS (требуется Microsoft Windows в качестве операционной системы, поскольку он использует драйвер SQLSRV).

Убедитесь, что установлен полнотекстовый модуль.

Некоторые пользователи считают полезным установить дополнительный программный пакет, такой как phpMyAdmin (MySQL / MariaDB) или phpPgAdmin (Postgres), для помощи в администрировании сервера базы данных.

MySQL 5 требуется начиная с MediaWiki 1.19. MySQL 4 требовался начиная с MediaWiki 1.6. (Если вы используете старую версию MySQL и не можете выполнить обновление, вам необходимо использовать MediaWiki 1.5.8, но эта версия не поддерживается.)

Требования к оборудованию

Рекомендуемые минимальные требования: 256 МБ ОЗУ для веб-сайта на одном компьютере и 85 МБ хранилища, хотя этого недостаточно для загруженного общедоступного сайта или сайта с включенной загрузкой.Некоторые пользователи сообщают, что MediaWiki запускается на компьютерах с объемом оперативной памяти всего 48 МБ.

Размер установки может быть уменьшен примерно до 50 МБ для установки разработчика и примерно до 26 МБ для установки конечного пользователя, не являющейся разработчиком. См. Руководство: Уменьшение размера установки.

Необязательные зависимости

Другое программное обеспечение [править]

  • Для создания эскизов изображений требуется ImageMagick или GD .
  • TeX требуется для встроенного отображения математических формул.В большинстве дистрибутивов на основе Debian / Ubuntu это пакет texlive .
  • Sendmail требуется для того, чтобы система могла отправлять электронные письма.
  • Доступ к оболочке требуется для запуска сценариев обслуживания; без него обновление MediaWiki может быть затруднено.
  • GNU diff3 может быть предоставлен для автоматического разрешения конфликтов.

Для получения дополнительной информации о вышеупомянутых элементах см. Руководство: Установка сторонних инструментов.

VisualEditor [править]

В MediaWiki версии 1.34 и более ранних для расширения VisualEditor (а также для расширения StructuredDiscussions (старый Flow)) требовался веб-сервис Parsoid, который был реализован с использованием Node.js. Node.js не предоставляется большинством компаний, предоставляющих общий хостинг (HostGator, Bluehost, Dreamhost и т. Д.). По соображениям производительности и безопасности лучше использовать решение для выделенного хостинга, такое как виртуальный частный сервер («VPS»).

Scribunto [править]

Если вы хотите вызывать модули Lua (см. Их на этой вики) со страниц и шаблонов вики, для вашей вики также потребуется Scribunto.

См. Также [править]

  • Совместимость, для получения информации о том, как требования к установке MediaWiki могут измениться в будущем
Пакеты программного обеспечения

Rancher Docs: Требования для установки

K3s очень легкий, но имеет некоторые минимальные требования, указанные ниже.

Независимо от того, настраиваете ли вы кластер K3s для работы в среде Docker или Kubernetes, каждый узел, на котором выполняется K3s, должен соответствовать следующим минимальным требованиям.Вам может потребоваться больше ресурсов для удовлетворения ваших потребностей.

Предварительные требования

Два узла не могут иметь одно и то же имя хоста.

Если все ваши узлы имеют одинаковое имя хоста, используйте параметр --with-node-id , чтобы добавить случайный суффикс для каждого узла, или иным образом придумайте уникальное имя для передачи с помощью --node-name или $ K3S_NODE_NAME для каждого узла, добавляемого в кластер.

Операционные системы

Ожидается, что

K3s будет работать на большинстве современных систем Linux.

Некоторые ОС предъявляют особые требования:

  • Если вы используете Raspbian Buster , выполните следующие действия, чтобы переключиться на устаревшие iptables.
  • Если вы используете Alpine Linux , выполните следующие действия для дополнительной настройки.
  • Если вы используете (Red Hat / CentOS) Enterprise Linux , выполните следующие действия для дополнительной настройки.

Дополнительные сведения о том, какие ОС были протестированы с управляемыми Rancher кластерами K3s, см. В условиях поддержки и обслуживания Rancher.

Оборудование

Требования к оборудованию масштабируются в зависимости от размера ваших развертываний. Здесь приведены минимальные рекомендации.

  • ОЗУ: минимум 512 МБ (рекомендуется не менее 1 ГБ)
  • ЦП: 1 Минимум

В этом разделе собраны результаты тестов для определения минимальных требований к ресурсам для агента K3s, сервера K3s с рабочей нагрузкой и сервера K3s с одним агентом. Он также содержит анализ того, что оказывает наибольшее влияние на использование сервера и агента K3s, и как можно защитить хранилище данных кластера от вмешательства со стороны агентов и рабочих нагрузок.

Диски
Производительность

K3s зависит от производительности базы данных. Чтобы обеспечить оптимальную скорость, мы рекомендуем по возможности использовать SSD. Производительность диска будет зависеть от устройств ARM, использующих SD-карту или eMMC.

Сеть

Серверу K3s необходимо, чтобы порт 6443 был доступен для всех узлов.

Узлы должны иметь возможность подключаться к другим узлам через порт UDP 8472, когда используется Flannel VXLAN. Узел не должен прослушивать любой другой порт. K3s использует обратное туннелирование, так что узлы устанавливают исходящие соединения с сервером, и весь трафик kubelet проходит через этот туннель.Однако, если вы не используете Flannel и предоставляете свой собственный CNI, порт 8472 не нужен K3s.

Если вы хотите использовать сервер метрик, вам необходимо открыть порт 10250 на каждом узле.

Если вы планируете достичь высокой доступности с помощью встроенного etcd, серверные узлы должны быть доступны друг другу на портах 2379 и 2380.

Важно: Порт VXLAN на узлах не должен быть открыт для всех, так как он открывает доступ к сети вашего кластера для всех.Запустите свои узлы за брандмауэром / группой безопасности, которая отключает доступ к порту 8472.

Входящие правила для узлов сервера K3s
Протокол Порт Источник Описание
TCP 6443 Узлы агента K3s Сервер API Kubernetes
UDP 8472 Сервер K3s и узлы агента Требуется только для Flannel VXLAN
TCP 10250 Сервер K3s и узлы агента Кубелет метрики
TCP 2379-2380 Серверные узлы K3s Требуется только для высокой доступности со встроенным etcd

Обычно разрешен весь исходящий трафик.

Большие кластеры

Требования к оборудованию зависят от размера вашего кластера K3s. Для производственных и больших кластеров мы рекомендуем использовать настройку высокой доступности с внешней базой данных. Следующие параметры рекомендуются для внешней базы данных в производстве:

ЦП и память

Ниже приведены минимальные требования к ЦП и памяти для узлов в сервере K3s высокой доступности:

Размер развертывания Узлы VCPUS RAM
Малый До 10 2 4 ГБ
Средний До 100 4 8 ГБ
Большой до 250 8 16 ГБ
Большой до 500 16 32 ГБ
XX большой 500+ 32 64 ГБ

Диски

Производительность кластера зависит от производительности базы данных.Чтобы обеспечить оптимальную скорость, мы рекомендуем всегда использовать SSD-диски для поддержки кластера K3s. Для облачных провайдеров вы также захотите использовать минимальный размер, который позволяет максимальное количество операций ввода-вывода в секунду.

Сеть

Вам следует подумать об увеличении размера подсети для кластера CIDR, чтобы у вас не закончились IP-адреса для модулей. Вы можете сделать это, передав параметр --cluster-cidr серверу K3s при запуске.

База данных

K3s поддерживает различные базы данных, включая MySQL, PostgreSQL, MariaDB и etcd, ниже приводится руководство по размеру ресурсов базы данных, необходимых для работы больших кластеров:

Размер развертывания Узлы VCPUS RAM
Малый До 10 1 2 ГБ
Средний До 100 2 8 ГБ
Большой до 250 4 16 ГБ
Большой до 500 8 32 ГБ
XX большой 500+ 16 64 ГБ

Требования для установки | Edge для частного облака v4.18.05

Edge для частного облака v4.18.05

Требования к оборудованию

Для обеспечения высокой доступности вы должны соответствовать следующим минимальным требованиям к оборудованию. инфраструктура в производственной среде.

Следующее видео дает общее руководство по выбору конфигурации для вашей установки:

Для всех сценариев установки, описанных в Топологии установки, в следующих таблицах перечислены минимальные аппаратные требования для компонентов установки.

В этих таблицах требования к жесткому диску указаны в дополнение к пространству на жестком диске, необходимому для операционная система. В зависимости от ваших приложений и сетевого трафика ваша установка может требуется больше или меньше ресурсов, чем указано ниже.

Установочный компонент RAM процессор Минимальный жесткий диск
Кассандра 16 ГБ 8-ядерный Локальное хранилище 250 ГБ с твердотельным накопителем или быстрым жестким диском с поддержкой 2000 операций ввода-вывода в секунду
Обработчик сообщений / маршрутизатор на том же компьютере 16 ГБ 8-ядерный 100 ГБ
Аналитика - Postgres / Qpid на том же сервере 16 ГБ * 8-ядерный * 500 ГБ - 1 ТБ ** сетевое хранилище *** , желательно с серверной частью SSD, поддержка 1000 IOPS или выше *
Аналитика - автономная версия Postgres 16 ГБ * 8-ядерный * 500 ГБ - 1 ТБ ** сетевое хранилище *** , желательно с серверной частью SSD, поддержка 1000 IOPS или выше *
Аналитика - автономный Qpid 8 ГБ 4-ядерный 30 ГБ - локальное хранилище 50 ГБ с твердотельным накопителем или быстрым жестким диском

Для инсталляций с производительностью более 250 TPS требуется жесткий диск с локальным хранилищем, поддерживающий 1000 IOPS. рекомендуемые.

Размер очереди Qpid по умолчанию составляет 20 ГБ. Если вам нужно увеличить емкость, добавьте дополнительные Узлы Qpid.

Другое (OpenLDAP, UI, Management Server) 4 ГБ 2-ядерный 60 ГБ

* Настройте системные требования Postgres в зависимости от пропускной способности:

  • Менее 250 TPS: 8 ГБ, 4 ядра можно рассмотреть с управляемой сетью хранилище *** с поддержкой 1000 IOPS или выше
  • Более 250 транзакций в секунду: 8-ядерное управляемое сетевое хранилище объемом 16 ГБ *** поддержка 1000 IOPS или выше
  • Более 1000 транзакций в секунду: 8-ядерное управляемое сетевое хранилище объемом 16 ГБ *** поддержка 2000 IOPS или выше
  • Более 2000 TPS: 32 ГБ, 16 ядер, управляемое сетевое хранилище *** поддержка 2000 IOPS или выше
  • Более 4000 транзакций в секунду: 64 ГБ, 32 ядра, управляемое сетевое хранилище *** поддержка 4000 IOPS или выше

** Значение жесткого диска Postgres основано на готовой аналитике, полученной Edge.Если вы добавляете пользовательские значения к данным аналитики, то эти значения следует увеличить. соответственно. Используйте следующую формулу, чтобы оценить необходимый объем хранилища:

байт необходимого хранилища =

(# байтов данных аналитики / запрос) *

(запросов / секунду) *

(секунд / час) *

(часов пиковой нагрузки в день) *

(дней / месяц) *

(месяцев хранения данных)

Например:

(2 Кбайт) * (100 запросов / сек) * (3600 сек / час) * (18 пиковых часов / день) * (30 дней / месяц) * (3 месяца хранения)

= 1 194 393 600 000 байт или 1194 .4 ГБ

*** Сетевое хранилище рекомендуется для базы данных Postgresql, потому что:

  • Это дает возможность динамически увеличивать размер хранилища, если и когда обязательный.
  • сетевых операций ввода-вывода в секунду можно отрегулировать на лету в большинстве современных окружающая среда / хранилище / сетевые подсистемы.
  • Моментальные снимки уровня хранилища можно включить как часть резервного копирования и восстановления решения.

Кроме того, ниже перечислены требования к оборудованию, если вы хотите установить Услуги по монетизации:

Компонент с монетизацией RAM процессор Жесткий диск
Сервер управления (со службами монетизации) 8 ГБ 4-ядерный 60 ГБ
Аналитика - Postgres / Qpid на том же сервере 16 ГБ 8-ядерный 500 ГБ - сетевое хранилище 1 ТБ, желательно с серверной частью SSD, поддерживающее 1000 операций ввода-вывода в секунду или выше или воспользуйтесь правилом из таблицы выше.
Аналитика - автономная версия Postgres 16 ГБ 8-ядерный 500 ГБ - сетевое хранилище 1 ТБ, желательно с серверной частью SSD, поддерживающее 1000 операций ввода-вывода в секунду или выше или воспользуйтесь правилом из таблицы выше.
Аналитика - автономный Qpid 8 ГБ 4-ядерный 40 ГБ - локальное хранилище 500 ГБ с твердотельным накопителем или быстрым жестким диском

Для инсталляций с производительностью более 250 TPS требуется жесткий диск с локальным хранилищем, поддерживающий 1000 IOPS. рекомендуемые.

Примечание :
  • Если размер корневой файловой системы недостаточно велик для установки, Apigee рекомендует что вы помещаете данные на диск большего размера.
  • Если на машине была установлена ​​более старая версия Apigee Edge for Private Cloud, убедитесь, что удалить каталог / tmp / java перед новой установкой.
  • Общесистемной временной папке / tmp требуются разрешения на выполнение, чтобы запустить Кассандру.
  • Если пользователь apigee был создан до установки, убедитесь, что / home / apigee существует как домашний каталог и принадлежит apigee: apigee .

Операционная система и сторонние требования к программному обеспечению

Эти инструкции по установке и прилагаемые установочные файлы были протестированы на операционные системы и стороннее программное обеспечение, перечисленные в Поддерживаемое программное обеспечение и поддерживаемые версии.

Создание пользователя apigee

В процессе установки создается системный пользователь Unix с именем apigee.Справочники Edge и файлы принадлежат apigee, как и процессы Edge. Это означает, что компоненты Edge работают как Пользователь apigee. при необходимости вы можете запускать компоненты от имени другого пользователя.

Каталог установки

По умолчанию программа установки записывает все файлы в каталог / opt / apigee . Ты не может изменить расположение этого каталога. Хотя вы не можете изменить этот каталог, вы можете создать символическая ссылка на карту / opt / apigee в другое место, как описано в Создание символической ссылки из / opt / apigee.

В инструкциях в этом руководстве каталог установки отмечен как / opt / apigee .

Создание символической ссылки из / opt / apigee

Перед тем, как создать символическую ссылку, вы должны сначала создать пользователя и группу с именем «apigee». Это та же группа и пользователь, созданные установщиком Edge.

Чтобы создать символическую ссылку, выполните эти шаги перед загрузкой файла bootstrap_4.18.05.sh. Вы должны выполнить все эти шаги как root:

  1. Создайте пользователя и группу apigee:
     groupadd -r apigee> useradd -r -g apigee -d / opt / apigee -s / sbin / nologin -c "Пользователь платформы Apigee" apigee 
  2. Создайте символическую ссылку из / opt / apigee на желаемый корень установки:
     ln -Ts  / srv / myInstallDir  / opt / apigee 

    Где / srv / myInstallDir - это желаемое расположение файлов Edge.

  3. Измените владельца корневого каталога установки и символическую ссылку на пользователя "apigee":
     chown -h apigee: apigee  / srv / myInstallDir  / opt / apigee 

Ява

Перед установкой на каждом компьютере должна быть установлена ​​поддерживаемая версия Java 1.8. Поддерживаемые JDK перечислены в Поддерживаемое программное обеспечение и поддерживаемые версии.

Убедитесь, что переменная среды JAVA_HOME указывает на корень JDK для пользователь, выполняющий установку.

Примечание: Установщик Edge может установить Java 1.8 и установить JAVA_HOME для вас как часть процесса установки apigee-setup . Дополнительные сведения см. В разделе Установка утилиты Edge apigee-setup.

SELinux

В зависимости от ваших настроек SELinux, Edge может столкнуться с проблемами при установке и запуске. Компоненты края. При необходимости вы можете отключить SELinux или установить его в разрешающий режим во время установки, а затем снова включите ее после установки.Дополнительные сведения см. В разделе Установка утилиты Edge apigee-setup.

Настройка сети

Apigee рекомендует проверить настройки сети перед установкой. Установщик ожидает, что все машины имеют фиксированные IP-адреса. Используйте следующие команды для проверки настройка:

  • hostname возвращает имя машины
  • hostname -i возвращает IP-адрес для имени хоста, к которому можно обращаться с другие машины.

В зависимости от типа и версии вашей операционной системы вам может потребоваться отредактировать / etc / hosts и / etc / sysconfig / network , если имя хоста не указано установить правильно. Дополнительную информацию см. В документации к вашей операционной системе.

Если на сервере несколько интерфейсных карт, команда "hostname -i" возвращает разделенные пробелами список IP-адресов. По умолчанию установщик Edge использует первый возвращенный IP-адрес, который может быть правильным не во всех ситуациях.В качестве альтернативы вы можете установить следующее свойство в файл конфигурации установки:

 ENABLE_DYNAMIC_HOSTIP = y 

Если для этого свойства установлено значение «y», программа установки предложит вам выбрать IP-адрес, который будет использоваться в качестве часть установки. Значение по умолчанию - «n». Видеть Справочник по файлу конфигурации Edge для получения дополнительной информации.

Предупреждение: Если вы установите ENABLE_DYNAMIC_HOSTIP = y , убедитесь, что в вашем файле свойств не установлено значение HOSTIP .

TCP Обертки

TCP Wrappers могут блокировать связь некоторых портов и могут влиять на OpenLDAP, Postgres и Установка Кассандры.На этих узлах проверьте /etc/hosts.allow и /etc/hosts.deny , чтобы убедиться, что нет ограничений порта для требуемого Порты OpenLDAP, Postgres и Cassandra.

iptables

Убедитесь, что нет политик iptables, препятствующих подключению между узлами на требуются пограничные порты. При необходимости вы можете остановить iptables во время установки с помощью команда:

 sudo / etc / init.d / iptables stop 

в CentOS 7.х:

 systemctl стоп firewalld 

Убедитесь, что Edge Router может доступ к /etc/rc.d/init.d/functions

Edge Router использует маршрутизатор Nginx и требует доступа для чтения по номеру /etc/rc.d/init.d/functions .

Если ваш процесс безопасности требует, чтобы вы установили разрешения на /etc/rc.d/init.d/functions , не устанавливайте их на 700, иначе маршрутизатор не сможет Начало. Разрешения могут быть установлены на 744, чтобы разрешить доступ для чтения к / etc / rc.d / init.d / функции .

Кассандра

Все узлы Cassandra должны быть подключены к кольцу. Кассандра хранит реплики данных на несколько узлов для обеспечения надежности и отказоустойчивости. Стратегия репликации для каждого Ключевое пространство Edge определяет узлы Cassandra, на которых размещаются реплики. Для получения дополнительной информации см. О кассандре коэффициент репликации и уровень согласованности.

Cassandra автоматически регулирует размер кучи Java в зависимости от доступной памяти. Для получения дополнительной информации см. Тюнинг Ресурсы Java в случае снижения производительности или большого потребления памяти.

После установки Edge для частного облака вы можете проверить, что Cassandra настроена. правильно, проверив /opt/apigee/apigee-cassandra/conf/cassandra.yaml файл. Например, убедитесь, что в сценарии установки Edge для частного облака заданы следующие недвижимость:

  • имя_кластера
  • initial_token
  • разделитель
  • семян
  • listen_address
  • rpc_address
  • снитч
Предупреждение : Не редактируйте файл cassandra.yaml файл.

База данных PostgreSQL

После установки Edge вы можете настроить следующие параметры базы данных PostgreSQL на основе объем оперативной памяти, доступной в вашей системе:

 conf_postgresql_shared_buffers = 35% ОЗУ # мин. 128 КБ
conf_postgresql_effective_cache_size = 45% ОЗУ
conf_postgresql_work_mem = 512 МБ # мин. 64 КБ 
Примечание: Эти настройки предполагают, что база данных PostgreSQL используется только для аналитики Edge, а не для каких-либо других целей.

Чтобы установить эти значения:

  1. Отредактируйте файл postgresql.properties:
     vi /opt/apigee/customer/application/postgresql.properties 

    Если файл не существует, создайте его.

  2. Задайте свойства, перечисленные выше.
  3. Сохраните изменения.
  4. Перезапустите базу данных PostgreSQL:
     / opt / apigee / apigee-service / bin / apigee-service apigee-postgresql перезапуск 

Системные ограничения

Убедитесь, что вы установили следующие системные ограничения для Cassandra и обработчика сообщений узлы:

  • На узлах Cassandra установите ограничения soft и hard memlock, nofile и адресное пространство (as) для установщик (по умолчанию "apigee") в / etc / security / limits.d / 90-apigee-edge-limits.conf как показано ниже:
     apigee soft memlock без ограничений
    apigee hard memlock без ограничений
    apigee soft nofile 32768
    apigee жесткий файл 65536
    apigee soft as безлимитный
    apigee hard as безлимитный 
  • На узлах обработчика сообщений установите максимальное количество дескрипторов открытых файлов равным 64 КБ. в /etc/security/limits.d/90-apigee-edge-limits.conf , как показано ниже:
     apigee soft nofile 32768
    apigee жесткий файл 65536 

    При необходимости вы можете увеличить этот лимит.Например, если у вас большое количество временные файлы открываются в любой момент.

Службы сетевой безопасности (NSS)

Network Security Services (NSS) - это набор библиотек, поддерживающих разработку клиентские и серверные приложения с поддержкой безопасности. Вы должны убедиться, что вы установили NSS v3.19 или новее.

Чтобы проверить текущую версию:

 ням информация nss 

Для обновления NSS:

 yum update nss 

См. Эту статью от RedHat для получения дополнительной информации.

Отключить поиск DNS на IPv6 при использовании NSCD (Name Service Cache Daemon)

Если вы установили и включили NSCD (Name Service Cache Daemon), обработчики сообщений сделайте два поиска в DNS: один для IPv4 и один для IPv6. Вы должны отключить поиск DNS на IPv6, когда с помощью NSCD.

Чтобы отключить поиск DNS на IPv6:

  1. На каждом узле обработчика сообщений отредактируйте /etc/nscd.conf
  2. Задайте следующее свойство:
     хостов включения-кеширования № 

Отключить IPv6 в Google Cloud Платформа для RedHat / CentOS 7

Если вы устанавливаете Edge на RedHat 7 или CentOS 7 на Google Cloud Platform, то вы должен отключить IPv6 на всех узлах Qpid.

См. Документацию RedHat или CentOS для вашей конкретной версии ОС для получения инструкций по отключение IPv6. Например, вы можете:

  1. Откройте / etc / hosts в редакторе.
  2. Вставьте символ "#" в первый столбец следующей строки, чтобы закомментировать его:
     # :: 1 localhost localhost.localdomain localhost6 localhost6.localdomain6 
  3. Сохраните файл.

AWS AMI

Если вы устанавливаете Edge на AWS Amazon Machine Image (AMI) для Red Hat Enterprise Linux 7.x, вы должны сначала запустить следующую команду:

 yum-config-manager --enable rhui-REGION-rhel-server-extras rhui-REGION-rhel-server-optional 

Программа установки использует следующие инструменты UNIX в стандартной версии, предоставляемой EL5 или EL6.

awk

выражение

libxslt

об / мин

разархивировать

базовое имя

grep

lua-сокет

об / мин 2cpio

пользователей Radd

баш

имя хоста

лс

СЭД

туалет

до н.э.

id

нетто-инструменты

судо

Wget

завиток

libaio

perl (из procps)

деготь

xerces-c

Сайрус-Сасл библиотека libdb4 pgrep (из procps) тр ням

дата

библиотека libdb-cxx

л.с.

uuid

chkconfig

имя каталога libibverbs pwd uname
эхо библиотека librdmacm питон
Примечание:
  • Исполняемый файл инструмента useradd находится в / usr / sbin и для chkconfig в / sbin .
  • С доступом sudo вы можете получить доступ к среде вызывающего пользователя, например, обычно вы вызываете sudo команду или sudo PATH = $ PATH: / usr / sbin: / sbin команда .
  • Убедитесь, что у вас установлен патч перед установкой пакета обновления (патча) монтаж.

ntpdate

Apigee рекомендует синхронизировать время ваших серверов. Если еще не настроен, Этой цели может служить утилита ntpdate , которая проверяет синхронизированы ли серверы по времени.Вы можете использовать yum install ntp для установки полезность. Это особенно полезно для репликации настроек OpenLDAP. Обратите внимание, что вы настроили сервер часовой пояс в формате UTC.

openldap 2,4

Для локальной установки требуется OpenLDAP 2.4. Если ваш сервер подключен к Интернету, затем скрипт установки Edge загружает и устанавливает OpenLDAP. Если у вашего сервера нет подключения к Интернету, вы должны убедиться, что OpenLDAP уже установлен перед запуском скрипта установки Edge.В RHEL / CentOS вы можете запустить yum install openldap-clients openldap-servers для установки OpenLDAP.

Для установок с 13 хостами и с 12 хостами с двумя центрами обработки данных OpenLDAP репликация требуется, потому что существует несколько узлов, на которых размещен OpenLDAP.

Межсетевые экраны и виртуальные хосты

Термин виртуальный обычно перегружается в ИТ-сфере, и поэтому это происходит с Apigee Edge для развертывания частного облака и виртуальных хостов.Чтобы уточнить, есть два основных использование термина виртуальный :

  • Виртуальные машины (ВМ) : Не требуется, но в некоторых развертываниях используется технология ВМ для создания изолированных серверов для своих компонентов Apigee. Узлы виртуальных машин, как и физические узлы, могут иметь сетевые интерфейсы и межсетевые экраны.
  • Виртуальные хосты : конечные веб-точки, аналогичные виртуальному хосту Apache.

Маршрутизатор в виртуальной машине может предоставлять несколько виртуальных хостов (если они отличаются друг от друга псевдоним хоста или порт интерфейса).

Как пример именования, на одном физическом сервере A могут быть запущены две виртуальные машины, названы «ВМ1» и «ВМ2». Предположим, что «VM1» предоставляет виртуальный интерфейс Ethernet, которому присвоено имя "eth0" внутри виртуальной машины, которому назначен IP-адрес 111.111.111.111 оборудование виртуализации или сетевой DHCP-сервер; а затем предположим, что VM2 предоставляет виртуальный Интерфейс Ethernet также называется "eth0", и ему назначается IP-адрес. 111.111.111.222 .

У нас может быть маршрутизатор Apigee, работающий на каждой из двух виртуальных машин. Маршрутизаторы предоставляют виртуальный хост конечные точки, как в этом гипотетическом примере:

Маршрутизатор Apigee в VM1 предоставляет три виртуальных хоста на своем интерфейсе eth0 (который имеет некоторые конкретный IP-адрес), api.mycompany.com:80 , api.mycompany.com:443 и test.mycompany.com:80 .

Маршрутизатор в VM2 предоставляет api.mycompany.com:80 (то же имя и порт, что и предоставленные ВМ1).

Операционная система физического хоста может иметь сетевой брандмауэр; если да, то этот брандмауэр должен быть настроен для передачи TCP-трафика, привязанного к портам, представленным на виртуализированном интерфейсы ( 111.111.111.111:{80, 443} и 111.111.111.222:80 ). В Кроме того, операционная система каждой виртуальной машины может предоставлять свой собственный брандмауэр на интерфейсе eth0, и эти также должен разрешать подключение трафика к портам 80 и 443.

Базовый путь - это третий компонент, участвующий в маршрутизации вызовов API к различным прокси API. которые вы, возможно, развернули.Пакеты прокси API могут совместно использовать конечную точку, если у них разные базовые пути. Например, один базовый путь может быть определен как http://api.mycompany.com:80/ а другой - http://api.mycompany.com:80/salesdemo .

В этом случае вам понадобится балансировщик нагрузки или какой-либо директор трафика, разделяющий http://api.mycompany.com:80/ трафик между двумя IP-адресами ( 111.111.111.111 на VM1 и 111.111.111.222 на VM2). Эта функция специфичен для вашей конкретной установки и настраивается вашей локальной сетевой группой.

Базовый путь устанавливается при развертывании API. Из приведенного выше примера вы можете развернуть два API, mycompany и testmycompany , для организации mycompany-org с виртуальным хостом с псевдонимом хоста api.mycompany.com и порт 80 . Если вы не декларируете basepath в развертывании, то маршрутизатор не знает, какой API отправлять входящие запросы к.

Однако, если вы развернете API testmycompany с базовым URL-адресом / salesdemo , затем пользователи получают доступ к этому API с помощью http: // api.mycompany.com:80/salesdemo . Если вы развернете свой API mycompany с базовый URL-адрес /, тогда ваши пользователи получают доступ к API по URL-адресу http://api.mycompany.com:80/ .

Лицензирование

Для каждой установки Edge требуется уникальный файл лицензии, который вы получаете от Apigee. Ты сможешь необходимо указать путь к файлу лицензии при установке сервера управления, например /tmp/license.txt.

Программа установки копирует файл лицензии на / opt / apigee / customer / conf / license.txt .

Если файл лицензии действителен, сервер управления проверяет срок действия и разрешенное сообщение. Количество процессоров (MP). Если срок действия какой-либо из настроек лицензии истек, вы можете найти журналы в следующее расположение: / opt / apigee / var / log / edge-management-server / logs . В этом случае вы можете связаться со службой поддержки Apigee для получения подробной информации о миграции.

Если у вас еще нет лицензии, свяжитесь с Apigee Sales.

.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *